0
Welcome Guest! Login
0 items Join Now

Gantry 5.4.26 not working properly

    • falcor's Avatar
    • falcor
    • Newbie
    • Posts: 3
    • Thanks: 0

    Gantry 5.4.26 not working properly

    Posted 1 year 5 months ago
    • Hello,

      This very well may be an issue on my server. If I update any of my RocketTheme joomla sites to Gantry 5.4.26 from 5.4.24 I get a blank page when I reload the site. The admin portal is fine, so I am able to install 5.4.24. I have the same failure with 5.4.25. All sites are Joomla 3.8.12, PhP 5.4.16 (Running CentOS minimal). All RocketTheme modules appear to be fully upgraded per Joomla's upgrade system. And I just downloaded the latest rocketinsaller for Denali to test if it was perhaps me using an older theme on another site. When I ask the site to display errors, so there isn't just a white page, the following is what I am presented with:

      Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /var/www/csp/libraries/gantry5/classes/Gantry/Component/Theme/AbstractTheme.php on line 92

      This is happening with test sites I have for Denali and Galatea. Any help would be appreciated. I can keep from updating to 5.4.26, but I would rather keep that updated.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 88504
    • Thanks: 11475
    • Web Designer/Developer

    Re: Gantry 5.4.26 not working properly

    Posted 1 year 5 months ago
    • The minimum requirement for G5.4.26 is PHP 5.5.9 - as you are using an older version of PHP this will be your issue. Please update PHP version (preferably to PHP 7.1+).

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.

Time to create page: 0.079 seconds