0
Welcome Guest! Login
0 items Join Now

SOLVED Not able to save layouts.

    • mcanimal's Avatar
    • mcanimal
    • Rocketeer
    • Posts: 67
    • Thanks: 2

    SOLVED Not able to save layouts.

    Posted 4 years 6 months ago
    • Hello, I'm working with Callisto though I assume this is a Gantry 5 issue. Most of my adjustments and changes in gantry are not saving. I've tried adding particles to the menu, adding positions and particles to layouts, and deleting outlines. None of it is saving after I make the change and select save. In most cases it tells me it saved, it looks ok, but when I navigate away then back, it returns to the default state.

      In this case I'm specifically trying to add breadcrumbs to all my layouts except the home layout. Using the Base Outline, I drop a module position in the showcase then assign it to the breadcrumb position by entering "breadcrumb" in the key of that particle. It says it saves then it does not keep when I refresh the page. I've tried doing this to the base outline and a theme outline.

      In the Outlines area I have deleted all unneeded outlines though I still see them listed. When I click delete again I am getting a 403 forbidden error.

      When clicking save, the Developer Debugger toolbar in Firefox is stating "Empty string passed to getElementById"

      UPDATE: I notice that in the Joomla side of the admin area the layouts that I deleted are in fact gone. They just remain in the Gantry listing when working with the outlines. Also, the breadcrumbs module I added does display on the front end, but the outline does not show that module being apart of the layout.

      Any ideas?

      The site is on a subdomain as a development site if that matters.
      site: www.wpz.alysondepp.com
    • Last Edit: 4 years 6 months ago by mcanimal.
    • http://www.mcanimalhospital.com
      http://www.washingtonparkzoo.com
    • DanG's Avatar
    • DanG
    • Preeminent Rocketeer
    • Posts: 36748
    • Thanks: 3226
    • Custom work done

    Re: SOLVED Not able to save layouts.

    Posted 4 years 6 months ago
    • mcanimal wrote:
      In this case I'm specifically trying to add breadcrumbs to all my layouts except the home layout. Using the Base Outline, I drop a module position in the showcase then assign it to the breadcrumb position by entering "breadcrumb" in the key of that particle. It says it saves then it does not keep when I refresh the page. I've tried doing this to the base outline and a theme outline.

      Currently Base Outline doesn't generate any layout to a web page. It's only a repository for the default colour, style and font settings.
    • mcanimal's Avatar
    • mcanimal
    • Rocketeer
    • Posts: 67
    • Thanks: 2

    Re: SOLVED Not able to save layouts.

    Posted 4 years 6 months ago
    • That's understandable, however I have also tried all this with the Default Layout, which is assigned to all of my pages (except home) and I get the same problem. Changes either do not save, or if they do save, the layout doesn't reflect the save even though the front end displays properly. In essence, I've added the breadcrumb to the default layout in the Showcase position. It works on the front end after i hit save, however the particle position does not remain in the Showcase position in the Outlines layout.
    • Last Edit: 4 years 6 months ago by mcanimal.
    • http://www.mcanimalhospital.com
      http://www.washingtonparkzoo.com
    • DanG's Avatar
    • DanG
    • Preeminent Rocketeer
    • Posts: 36748
    • Thanks: 3226
    • Custom work done

    Re: SOLVED Not able to save layouts.

    Posted 4 years 6 months ago
    • Would you please create a Super Admin login for me and place it in the SECURE part of your Reply

      This image is hidden for guests.
      Please log in or register to see it.


      so that I can take a look.
    • mcanimal's Avatar
    • mcanimal
    • Rocketeer
    • Posts: 67
    • Thanks: 2

    Re: SOLVED Not able to save layouts.

    Posted 4 years 6 months ago
    • Thank you for looking into this.

      Today when looking at the backend, things seem to be in order at first. Items seem to be saving correctly. I would have suspected cache, but I never turned it on and since it seems ok today event though I have not made any changes. Odly seems to be an intermitten problem. I had intermitten trouble twice before posting to the forum.

      Now after working for a while, I'm finding the same issue with assigning the Default Layout to all menu items except Home. It acts like it saves, but when navigating away and back they display as if reverted to their previous state.
      However, it appears the changes did in fact save as the front end is working accordingly. Just the backend is not reflecting the save.

      I keep adding to this post as I figure more out...

      Update:
      Tongiht I set the "Base Outline" Contacts particle to include all relevant info and can see it updated but with check boxes greyed out on the "Callisto - Home" outline and the "Default Layout" outline (the two I'm using). I've applied it to the site and can see it on the front end. However, I wanted to make a change to that particle so I went to the "Base Outline" to edit the source. Now it is back to the default blank settings. However it still shows up correctly but in the greyed out state on the "Callisto - Home" outline. I don't want to edit it there as I'll have to start editing it for every outline I intend to use in the future.
    • Last Edit: 4 years 6 months ago by mcanimal.
    • http://www.mcanimalhospital.com
      http://www.washingtonparkzoo.com
    • mcanimal's Avatar
    • mcanimal
    • Rocketeer
    • Posts: 67
    • Thanks: 2

    Re: SOLVED Not able to save layouts.

    Posted 4 years 6 months ago
    • DanG's Avatar
    • DanG
    • Preeminent Rocketeer
    • Posts: 36748
    • Thanks: 3226
    • Custom work done

    Re: SOLVED Not able to save layouts.

    Posted 4 years 6 months ago
    • mcanimal wrote:
      Update:
      Tongiht I set the "Base Outline" Contacts particle to include all relevant info and can see it updated but with check boxes greyed out on the "Callisto - Home" outline and the "Default Layout" outline (the two I'm using). I've applied it to the site and can see it on the front end. However, I wanted to make a change to that particle so I went to the "Base Outline" to edit the source. Now it is back to the default blank settings. However it still shows up correctly but in the greyed out state on the "Callisto - Home" outline. I don't want to edit it there as I'll have to start editing it for every outline I intend to use in the future.

      The greyed out is just a default entry view of that modal window. For example in your Callisto Home outline I changed the Contact particle so that the Title says Cintact Us. I had no issues.
  • Re: SOLVED Not able to save layouts.

    Posted 4 years 2 months ago
    • I have similar issues with Callisto and Gantry 5. I am unable to change theme styles. Also, when I press Extras in Gantry 5. I do not get a drop-down menu.I have not found a solution. But, I have noticed a pattern. The problem for me, seems to be with Firefox. I am currently using Firefox 30.0. I opened my Admin in Opera 12.16, and it seemed to work. I was able to change theme. And also, I can see the gantry Extras menu. However, when I change the style. Although it shows that it has changed in the admin. It does not change on the actual site.
    • DanG's Avatar
    • DanG
    • Preeminent Rocketeer
    • Posts: 36748
    • Thanks: 3226
    • Custom work done

    Re: SOLVED Not able to save layouts.

    Posted 4 years 2 months ago
    • JD Starz wrote:
      I have similar issues with Callisto and Gantry 5. I am unable to change theme styles. Also, when I press Extras in Gantry 5. I do not get a drop-down menu.I have not found a solution. But, I have noticed a pattern. The problem for me, seems to be with Firefox. I am currently using Firefox 30.0. I opened my Admin in Opera 12.16, and it seemed to work. I was able to change theme. And also, I can see the gantry Extras menu. However, when I change the style. Although it shows that it has changed in the admin. It does not change on the actual site.

      Umm...Firefox currently is at version 42.0.1 so yours is very outdated. As for the Styles are you sure your changing them in the Outline that is assigned to the Menu page you wish to affect?
  • Re: SOLVED Not able to save layouts.

    Posted 2 months 3 days ago
    • It's the end of 2019, and Firefox v 70.0.1 and Gantry 5 are still not playing nice together. Thank you to the poster from 4 years ago - switching to Chrome worked for me.

Time to create page: 0.085 seconds