0
Welcome Guest! Login
0 items Join Now

RokBox 2.52 with WordPress 4.9.12 Ubuntu 18.04 LTS

  • RokBox 2.52 with WordPress 4.9.12 Ubuntu 18.04 LTS

    Posted 2 months 3 weeks ago
    • The plugin RokBox 2.52 is not working with default wordpress package.

      The root cause is a function name conflict. Indeed window.getSize() is already used.
      I suggest to the plugin maintainer to replace this function name by something more specific to the plugin like mooGetSize()

      I tested by replacing myself in wp-content/plugins/wp_rokbox/assets/js/mootools.js and wp-content/plugins/wp_rokbox/assets/js/rokbox.js each occurence of "getSize(" by "mooGetSize(" with success...


      Regards,

      Alain Degreffe
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 87298
    • Thanks: 11273
    • Web Designer/Developer

    Re: RokBox 2.52 with WordPress 4.9.12 Ubuntu 18.04 LTS

    Posted 2 months 3 weeks ago
    • Thank you for your suggestion but that's the first we have heard of this so I will check it out.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
  • Re: RokBox 2.52 with WordPress 4.9.12 Ubuntu 18.04 LTS

    Posted 2 months 3 weeks ago
    • Hi Mark,

      After more investigations, the conflict exists with masonry library wich provide rich grid layout used by lot of WordPress Themes.

      So it is very difficult to change it...

      Alain
    • Last Edit: 2 months 3 weeks ago by Alain Degreffe.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 87298
    • Thanks: 11273
    • Web Designer/Developer

    Re: RokBox 2.52 with WordPress 4.9.12 Ubuntu 18.04 LTS

    Posted 2 months 3 weeks ago
    • Ok thanks for letting us know. Unfortunately I can't see that any further enhancements will be made to rokbox as this is an old extension that relies on Mootools. When WP introduced the Gutenberg editor this did give rise to some issues with rokox which in the main we did address. However, if you are using the advanced facilities of the Gutenberg editor (like the rich grid layout) then you may well still have issues. This is why I recomment that if you are using Gantry 5, in the first instance I suggest using lightcase rather than rokbox, and then also using the "classic" editor rather than Gutenberg (available on plugins page of WP).

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.

Time to create page: 0.063 seconds