0
Welcome Guest! Login
0 items Join Now

SOLVED Rok Gallery - Invalid response

    • Axelschi's Avatar
    • Axelschi
    • Jr. Rocketeer
    • Posts: 22
    • Thanks: 0

    SOLVED Rok Gallery - Invalid response

    Posted 1 month 1 week ago
    • Hi there,
      when i try to add a tag to images i receive the follwing error message:

      Add Tag - Invalid Response

      The response from the server had an invalid JSON string while adding Tags. Following is the reply.

      Fatal error: Allowed memory size of 28004500 bytes exhausted (tried to allocate 8192 bytes) in /homepages/xxxxxxxxxxxx/components/com_rokgallery/lib/WideImage/TrueColorImage.php on line 54

      My configuration is:
      Joomla 3.9.14
      PHP 7.3.13
      Rok Gallery 2.45
      Rok common 3.2.8
      json support enabled
      json version 1.7.0

      The images a add are around 120kb (1240x600)
      How can i fix the problem?
    • Last Edit: 1 month 1 week ago by Axelschi.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 87917
    • Thanks: 11365
    • Web Designer/Developer

    Re: Rok Gallery - Invalid response

    Posted 1 month 1 week ago
    • Your php memory_limit is far too low - increase this to at least 128M.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
    • Axelschi's Avatar
    • Axelschi
    • Jr. Rocketeer
    • Posts: 22
    • Thanks: 0

    Re: Rok Gallery - Invalid response

    Posted 1 month 1 week ago
    • Hi Mark, thanks for your answer. The Memory_limit is at 256M but i still get the error. What else could be the problem?
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 87917
    • Thanks: 11365
    • Web Designer/Developer

    Re: Rok Gallery - Invalid response

    Posted 1 month 1 week ago
    • If you still get the error then that can't be your memory_Limit. Check with system > system information > php information and see what it says there for php memory_limit.

      Please would you post your URL, superuser id and pswd in the secure tab of your post and I'll have a look for you.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
    • Axelschi's Avatar
    • Axelschi
    • Jr. Rocketeer
    • Posts: 22
    • Thanks: 0

    Re: Rok Gallery - Invalid response

    Posted 1 month 1 week ago
    • This message contains only secure information that is visible to MrT, moderators and administrators
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 87917
    • Thanks: 11365
    • Web Designer/Developer

    Re: Rok Gallery - Invalid response

    Posted 1 month 1 week ago
    • Yep, I've seen that before on shared hosting environments. The "-1" is supposed to mean "use whatever you are allowed" but it doesn't work in some environments so set it explicitly to 256M instead in your plesk/cPanel or php.ini.

      Regards, Mark.
    • Last Edit: 1 month 1 week ago by MrT.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.
    • Axelschi's Avatar
    • Axelschi
    • Jr. Rocketeer
    • Posts: 22
    • Thanks: 0

    Re: Rok Gallery - Invalid response

    Posted 1 month 1 week ago
    • Ok,thank you.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 87917
    • Thanks: 11365
    • Web Designer/Developer

    Re: Rok Gallery - Invalid response

    Posted 1 month 1 week ago
    • Please let us know the outcome.

      If your issue is now solved, please EDIT your FIRST POST in this thread by adding [SOLVED] at the start of the title and then select the TICK icon. This lets the moderators know that it can be moved to the solved section.

      If you can't edit the first post this will be because it is more than 7 days old, so please reply stating that the topic can be closed and a moderator will do this for you.



      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.

Time to create page: 0.093 seconds